به بخش پرسش و پاسخ یادگیری عمیق خوش آمدید,
این نسخه آزمایشی سایت است.
لطفا به نکات زیر توجه کنید:
  • برای ارتباط با مدیران میتوانید از صفحه مدیران اقدام کنید.
  • سوال و جواب ها باید به زبان فارسی باشند. استفاده از زبان انگلیسی یا فینگلیش برای پاسخ دادن مجاز نیست.
  • لطفا بعد از پرسش سوال لینک سوال خود را در گرو تلگرام (Iran Deep Learning Group) معرفی کنید تا سریعتر به جواب برسید. برای دسترسی به آخرین لینک از منابع یادگیری استفاده کنید
  • لطفا بجای عکس از متن استفاده کنید. اگر متون طولانی هستند از سایت pastebin.com برای اپلود استفاده کرده و لینک حاصل را در سوال خود قرار دهید. برای قرار دادن تصویر ، از بخش ارسال تصویر ادیتور سایت استفاده کنید.
  • بعد از دریافت پاسخ، بهترین پاسخ را از طریق کلیک بر روی علامت تیک انتخاب کنید
  • اگر با خطا و یا مشکلی مواجه شدید از بخش تماس با ما در انتهای صفحه و یا ایمیل Coderx7@gmail.com موضوع را اطلاع دهید.

با تشکر

0 امتیاز

با سلام
من قصد اجرای اسکریپت های پایتون رو داشتم که با این خطا مواجه شدم:

Traceback (most recent call last):
  File "C:/Users/KamanGir/Desktop/thesis/deep-learning/tool-requierment/stup-for-caffe/caffe-windows-new/caffe-windows/python/extract/caffe_feature_extractor.py", line 23, in <module>
    import caffe
  File "C://Users//KamanGir//Desktop//thesis//deep-learning//tool-requierment//stup-for-caffe//caffe-windows-new//caffe-windows//python\caffe\__init__.py", line 1, in <module>
    from .pycaffe import Net, SGDSolver, NesterovSolver, AdaGradSolver, RMSPropSolver, AdaDeltaSolver, AdamSolver
  File "C://Users//KamanGir//Desktop//thesis//deep-learning//tool-requierment//stup-for-caffe//caffe-windows-new//caffe-windows//python\caffe\pycaffe.py", line 13, in <module>
    from ._caffe import Net, SGDSolver, NesterovSolver, AdaGradSolver, \
ImportError: No module named 'caffe._caffe'

من پایتون 3.5.2 و اناکوندای 4.2.0 نصب کردم. کفی هم به درستی بیلد شد و از دستور زیر هم در اسکریپت استفاده می کنم:

sys.path.insert(0, caffe_root + 'python')

پوشه کفی در پوشه پایتون در دایرکتوری کفی را هم در site package کپی کردم. ولی همچنان این ارور را میگیرم.
ممکنه بفرمایید از چه چیزی میتونه باشه؟ من پایتون جدیدی هم نصب نکردم. فقط همون ورژن 3.5.2 هست. و کفی را هم با ویژوال 2013 بیلد کردم.

سوال شده توسط (150 امتیاز)

1 پاسخ

0 امتیاز
 
بهترین پاسخ

سلام
دوتا نکته
اولا وقتی شما پوشه کفی رو داخل site packages کپی کردید دیگه نیازی به مشخص کردن پوشه بصورت دینامیک ندارید . یعنی دستوری که نوشتید فقط وقتی بزنید که تو sitepackages چیزی رو کپی نکردید .

نکته بعدی هم اینکه شما به اون توجهی که من اول اموزش دادم اصلا توجه نکردید »

قبل از نصب کفی شما باید موارد زیر رو دانلود و نصب کنید »
.. ..
Visual Studio 2015/2013 الان ترجیح با ۲۰۱۵ هست . ویژوال استودیو ۲۰۱۵
از هر دو ورژن پایتون(۲ و ۳) پشتیبانی میکنه . اما ۲۰۱۳ فقط از پایتون ۲٫

یعنی با ویژوال استودیو 2013 فقط باید از پایتون2 استفاده کنید.

پاسخ داده شده توسط (4.3k امتیاز)
انتخاب شده توسط
...