Deprecated: Function get_magic_quotes_gpc() is deprecated in /home/ustmbir/domains/deeplearning.ir/public_html/qa/qa-include/qa-base.php on line 1177
خطا در import کردن openface - پرسش و پاسخ یادگیری عمیق
به بخش پرسش و پاسخ یادگیری عمیق خوش آمدید,
این نسخه آزمایشی سایت است.
لطفا به نکات زیر توجه کنید:
  • برای ارتباط با مدیران میتوانید از صفحه مدیران اقدام کنید.
  • سوال و جواب ها باید به زبان فارسی باشند. استفاده از زبان انگلیسی یا فینگلیش برای پاسخ دادن مجاز نیست.
  • لطفا بعد از پرسش سوال لینک سوال خود را در گرو تلگرام (Iran Deep Learning Group) معرفی کنید تا سریعتر به جواب برسید. برای دسترسی به آخرین لینک از منابع یادگیری استفاده کنید
  • لطفا بجای عکس از متن استفاده کنید. اگر متون طولانی هستند از سایت pastebin.com برای اپلود استفاده کرده و لینک حاصل را در سوال خود قرار دهید. برای قرار دادن تصویر ، از بخش ارسال تصویر ادیتور سایت استفاده کنید.
  • بعد از دریافت پاسخ، بهترین پاسخ را از طریق کلیک بر روی علامت تیک انتخاب کنید
  • اگر با خطا و یا مشکلی مواجه شدید از بخش تماس با ما در انتهای صفحه و یا ایمیل Coderx7@gmail.com موضوع را اطلاع دهید.

با تشکر

دسته بندی ها

0 امتیاز

سلام.
من کدی رو ران میکنم و ارور زیر رو میگیرم :

ImportError: No module named openface

روی ویندوز با چه دستوری میتونم openface رو نصب کنم؟؟؟؟

توسط (107 امتیاز)
ویرایش شده توسط

1 پاسخ

+1 امتیاز

openface اسم کتابخانه ای هست که به زبان پایتون نوشته شده تا کد رو اجرا کنه. شما باید از قبل torch و پایتون رو نصب داشته باشید. پروژه رو از گیت هاب دانلود کنید و برای رفع این ارور کدی رو که میخواید اجرا کنید جوری جابه جا کنید تا پوشه openface رو در کنار خودش داشته باشه. وقتی توی کد مینویسه import openface یعنی توقع داره اونو کنار خودش ببینه.
اما نکته اساسی اینه که من سایت پروژه رو نگاه کردم نوشته ستاپ فقط برای لینوکس و مک ساپورت شده. یعنی این کد به همین شکل روی ویندوز اجرا نمیشه مگر این که خودتون اصلاحش کنید.( به منوی userguide و سپس setup برید)
openface

توسط (200 امتیاز)
ممنونم که وقت گذاشتین.
ببخشید اینجا از docher استفاده کرده برای زدن کدها در لینوکس.ایا ضرورتی هست در این استفاده؟؟؟مثلا من vmware استفاده کنم اشکالی داره؟؟
ببینید بعضی از دستورات و کتابخانه ها توی سیستم عامل های متفاوت مشترک نیستن و کدهایی مثل این چون بعضا از یک سری ویژگی های سیستمی استفاده میکنند به همین خاطر با این که به زبان پایتون هستن اما فقط توی همون سیستم عاملی که نوشته شدن قابل اجرا هستن. به همین خاطر یا باید از سیستم عامل مشابه استفاده کنید یا خودتون ویرایشش کنید و ارورها رو بر طرف کنید.
docker محیطی است که یک محیط پایتون مجزای از اون چیزی که روی سیستم شما است برای شما ایجاد میکنه. یه مثال ساده از کاربردش براتون بزنم اینه که شما مثلا روی پایتونی که توی سیستم نصبه کتابخانه numpy 10 رو دارید اما مثلا برای این کد به نسخه 11 نیازه و شما نمیخواید نسخه سیستمتون رو عوض کنید. برای این کار docker یا virtualenv مناسبه. فکر نکنم از vmware بشه استفاده کرد. تا جایی که میدونم این دو کاملا متفاوتن با هم.

یه نکته مجزا از این ها هم بگم شاید به کارتون بیاد. تا جایی که میدونم روی ماشین مجازی که با vmware بالا میاد کارت گرافیک یا همون GPU رو نمیشه دید. بنابراین اگر میخواید این کد رو با GPU ران کنید لینوکس رو روی vmware نصب نکنید. بلکه اون کنار ویندوزتون نصب کنید به عنوان سیسم عامل دوم.
منظورتون از ویرایشش کنین چیه؟؟ یعنی الان با داکر میشه کاری کرد که من کد رو ویرایش کنم و توی همون ویندوز ران بگیرم؟؟؟
...