به بخش پرسش و پاسخ یادگیری عمیق خوش آمدید,
این نسخه آزمایشی سایت است.
لطفا به نکات زیر توجه کنید:
  • برای ارتباط با مدیران میتوانید از صفحه مدیران اقدام کنید.
  • سوال و جواب ها باید به زبان فارسی باشند. استفاده از زبان انگلیسی یا فینگلیش برای پاسخ دادن مجاز نیست.
  • لطفا بعد از پرسش سوال لینک سوال خود را در گرو تلگرام (Iran Deep Learning Group) معرفی کنید تا سریعتر به جواب برسید. برای دسترسی به آخرین لینک از منابع یادگیری استفاده کنید
  • لطفا بجای عکس از متن استفاده کنید. اگر متون طولانی هستند از سایت pastebin.com برای اپلود استفاده کرده و لینک حاصل را در سوال خود قرار دهید. برای قرار دادن تصویر ، از بخش ارسال تصویر ادیتور سایت استفاده کنید.
  • بعد از دریافت پاسخ، بهترین پاسخ را از طریق کلیک بر روی علامت تیک انتخاب کنید
  • اگر با خطا و یا مشکلی مواجه شدید از بخش تماس با ما در انتهای صفحه و یا ایمیل Coderx7@gmail.com موضوع را اطلاع دهید.

با تشکر

0 امتیاز

سلام دوستان
قصد دارم caffe را برای کارت gtx1070 نصب کنم. با cuda7.5 کامپایل نمیشه و خطا میده. سرچ کردم دیدم cuda8 این کارت رو ساپورت میکنه و برای کامپایل هم باید از ویژوال ۲۰۱۵ استفاده کرد. همه ‌ی این کار ها را انجام دادم یعنی cuda8 و cuDNN5 را نصب کردم و از ویژوال ۲۰۱۵ هم استفاده کردم. ولی پکیج های ناگتی که دانلود میکنه با این کدها هماهنگ نیست. لطفا اگر کسی در این مورد اطلاعاتی داره و قبلا برای این کارت گرافیکی caffe را نصب کرده من رو راهنمایی کنه.
ممنون
شاکر

سوال شده توسط (131 امتیاز)
برچسب گذاری دوباره توسط
شما مشکلتون برطرف شد ؟ من امروز کفی رو در ویندو ز10 با کودا 8 و cudnn5.1 و ویژوال استودیو 2013 براحتی نصب کردم و مشکلی نبود. آ[رین بیلد کفی رو تست کنید نباید مشکلی باشه.

1 پاسخ

0 امتیاز
 
بهترین پاسخ

سلام .
برای استفاده از Cuda 8 نباید مشکلی در استفاده از ویژوال استودیو 2013 داشته باشید.
من آخرین ورژن Caffe رو با Cudnn5.1 و Cuda8 تو ویندوز 10 بدون هیچ مشکلی کامپایل و اجرا کردم (ویژوال استودیو 2013 . دقت کنید که برای استفاده از کودا 8 باید از روش جدید(cmake) استفاده کنید. که الان خیلی راحت شده کامپایلش.
بنظر میاد خود ویژوال استودیو۲۰۱۳ (solution ش منظورم هست )‌ با کودا ۸ سازگار نیست .
برای اینکه براحتی نصب کنید دوتا نکته باید در نظر داشته باشید . من طی سرچایی که کرده بودم گفته بودن خصوصا ویندوز ۱۰ باید ورژ» ۱۶۰۷ باشه (redstone ) .
بعد از اون شما خیلی راحت آخرین ورژن کفی رو دانلود کنید . برید تو پوشه scripts . اونجا فایل build_win.cmd رو باز کنید (تو نوت پد یا نوت پد++ )‌و بخشای مورد نیاز رو ویرایش کنید . (مثل بخش مربوط به محل نصب آناکوندا یا مینی کوندا (هرکدوم که نصب کردید)‌ بعد هم مشخص کنید که از ویژوال استودیو ۲۰۱۳ دارید استفاده میکنید ( پایین تر ۱۴ رو به ۱۲ تغییر بدید (کامنت داره مشخص هست )‌ .
بعد هم از روت کفی اسکرپت رو اجرا کنید .
این نمونه فایل من هست که با5.1‍ cudnn‍‍‍‍‍‍‍‍‍‍‍‍ کامپایل میکنه : build_win.cmd
یادتون باشه ممکنه این اسکریپت رو اجرا میکنید dependency ها رو به path اضافه نکنه (برای من نکرد) و من خودم محتویات پوشه dependency و به path اضافه کردم .(ضمنا یادتون باشه محتویات فایل من رو برای خودتون کپی پیست نکنید! چون در ادامه ممکنه ورژن جدید بیاد و شما با این کار خراب کنید همه چیز رو . سعی کنید ببینید و گزینه ها رو مطابقت بدید اگه دیدید خیلی فرق میکنن کامنت بزارید تا توضیحات جدید داده بشه)
علاوه بر اون یادتون باشه برای رپر پایتون هم حتما اون کانال های مربوطه رو اضافه کنید . یعنی این بخش رو اگر دیدید که ایمپورت کردید کفی و ارور دارد دوباره دستی بزنید این کدها رو :‌

 //Add the required channels
conda config —add channels conda-forge
conda config —add channels willyd
// Update conda
conda update conda -y
//Create an environment
// Todo create protobuf package for vc12
conda install —yes cmake ninja numpy scipy protobuf==3.1.0.vc12 
conda install six scikit-image

این کارها رو بکنید نباید مشکل داشته باشید و باید براحتی کامپایل انجام بشه و بتونید ران بگیرید
cmake هم قبلش دانلود کنید
و بعد اگر نصب کننده خودش cmake رو به path اضافه نکرد شما بکنید.
به هر حال شاید روشهای زیر برای کسایی مفید باشه هرچند هیچ نیازی به اینها نیست :
اینجا رو ببینید . راه حلهایی که اینجا اومده هم ممکنه مشکل شما رو برطرف بکنه

پاسخ داده شده توسط (4.3k امتیاز)
انتخاب شده توسط
طریقه کامپایل با استفاده از cmake
...